Author shown even with “Display Post author details” disabled

  • Author shown even with “Display Post author details” disabled
    Viewing 6 posts - 1 through 6 (of 6 total)

  • Apprique
    Participant
    #2310

    The author keeps being shown on individual posts, even though under Theme Options->Page settings->Post page “Display Post author details” is disabled. A similar setting on Template blog page settings does correctly hide the author on the top level Blog page.


    Omar
    Keymaster
    #2336

    Hey Apprique,

    Sorry for the late reply,

    The setting in theme options if for the Admin Bio at the end of the single blog post,
    What you need would be some CSS like

    .postAuthor{
    display: none;
    }

    and if you’re planning on removing all the info. over the featured image like categories and views

    .postCreagory.clearfix{
    display: none;
    }

    Regards.


    txspurgin
    Participant
    #2450

    Shall I assume this is true for the date as well?
    I would like to never show the author and never show the date for all posts, regardless of where the post appears.
    Is the only solution current via CSS edit?


    Omar
    Keymaster
    #2482

    Hello James,

    You are correct, the Show/Hide option is for the Blog template page
    you would have to use CSS to remove it from the single view

    .postDate{
    display:none;
    }

    I will get options added for the Single Post Page as well, Thanks for your feedback Apprique and James.

    Cheers.


    txspurgin
    Participant
    #2536

    Omar,
    CSS code definitely worked for the individual posts, however, the date and author are still showing on the listings page of posts. For example, I am using the “Posts Block” Content option in the Content Builder for a particular page in which I want to show a listing of a category of posts. Using the “Magazine Style 3”, the listing of posts still shows the date and author under the image for each of the posts when the page is live.
    Any further help would be greatly appreciated.
    THX
    James


    Omar
    Keymaster
    #2553

    Hey James,

    To remove the post date and the author from the magazine styled post block you would need to add
    .magazinePostDate{
    display: none;
    }

    It was displaying because it uses a different class called magazinePostAuthor

    Cheers

Viewing 6 posts - 1 through 6 (of 6 total)

The topic ‘Author shown even with “Display Post author details” disabled’ is closed to new replies.