Content Disappearing (Blocks Not Saving)

  • Content Disappearing (Blocks Not Saving)
    Viewing 12 posts - 1 through 12 (of 12 total)

  • Omar
    Keymaster
    #2293

    Hey everyone,

    In the case you’re experiencing blocks disappearing when you update your pages, that is due to the limit on the vale of max_input_vars in the php configuration.

    The Content Builder surely make life easy, but it sends a fair amount of Variables to the server when posting/editing.
    This will not make your website slow! Don’t worry.

    Please contact your server admin and ask to increase the value of max_input_vars to 10000 to avoid having this problem again.

    Cheers.


    Apprique
    Participant
    #2309

    Not everyone has the luxury of their website hosting admins changing these variables. Is there another solution?


    Omar
    Keymaster
    #2363

    Hey Apprique,

    Well sadly not currently, the Content Builder saving relies heavily on POST, any user wanting to save a page with 40+ blocks would need to increase max_input_vars to a minimum of 2000

    Regards.


    sohieb
    Participant
    #3384

    i have talked with host support
    and it’s now
    ; How many GET/POST/COOKIE input variables may be accepted
    ; max_input_vars = 10000

    and i still have same problem


    missionc
    Participant
    #3452

    Which PHP file does the max_input_vars input exist in?


    Omar
    Keymaster
    #3507

    Hello Missionc,

    Sorry for the very late reply, we’ve missed your post.
    max_input_vars are server realted.
    If you have control over php.ini you should be able to edit it, otherwise you would need to contact your hosting providers and ask them to increase the value for you.

    Cheers.


    gdupes
    Participant
    #4238

    I too have changed my max_input_vars and i am having this problem still.


    Pericles
    Participant
    #7398

    I think that content builder allow maximum 60 elements


    eblomme
    Participant
    #7778

    Hey all! We were having this issue as well. We downloaded a Super Cacher plug in. Before I add a new column, I use the purge cache and then add column/blocks and update and it stays every time! Hope this helps someone!


    RevAssure
    Participant
    #8016

    Hi Omar!

    I can’t figure out how to start a new forum to ask you a question, but I am also having trouble with blocks being erased on my website pages. Also when I add bullet point, the rest of the text in the text box loses its ability to have a transparent background. Can you please get back to me about how to fix both of these problems? And let me know how to ask you questions directly in the future?

    Thanks!


    kimbly.george
    Participant
    #8749

    Hi Omar

    I have had this problem and contacted my web host to increase the size. Once done, will the blocks which have disappeared come back please?

    Kim


    Bishoy Melek
    Moderator
    #9169

    Hello all,

    I have missed this post and I’m so sorry about that. Please accept my apologies!

    @gdupes if the problem still exists on your website, please let me know and I will help you as soon as possible.

    @pericles @eblomme thank you so much; Actually it depends on the max_input_var which you can control it from php.ini file or by asking the hosting providers to change it for you. it doesn’t have a specific number of blocks you can add.

    @revassure are you still facing the issue about the blocks being erased? if yes please give me admin credentials and FTP access to your website so that I can fix it for you as soon as possible. About starting a topic in the forum, first you have to register to have an account, then go to the topics list and at the bottom of the page you will find a box to add your topic and post it.

    @kimbly.george
    Unfortunately, not. Those blocks are lost and need to be created once again.

    My Regards

Viewing 12 posts - 1 through 12 (of 12 total)

The topic ‘Content Disappearing (Blocks Not Saving)’ is closed to new replies.