Edit Page Timing Out & Pre Saved Template Missing

  • Edit Page Timing Out & Pre Saved Template Missing
    Viewing 11 posts - 31 through 41 (of 41 total)

  • Omar
    Keymaster
    #4002

    Hello YachtMaster,

    Counting the number of inputs sent by your page, it turns out to be 1067
    Please increase the value of max_input_vars in your php.ini

    You will probably need to check with your hosting provider and ask them to increase it for you.

    Regards


    yachtmaster
    Participant
    #4005

    Hi Omar!

    I’ve increased value of max_input_vars and now everything is fine.
    Thank you for guidance!

    How did you check current value of number of inputs? I’ve set the number to 3000 now, I hope it won’t go above that now 🙂


    Omar
    Keymaster
    #4028

    Hello YachtMaster,

    I checked it while editing the page
    Open developer tools of browser, mostly “right click -> Inspect elements”

    Then in the console tab write the code
    jQuery(‘input’).length;

    That’s it 🙂
    That would give a rough amount of number of inputs sent when you update the page

    Cheers


    yachtmaster
    Participant
    #4032

    Hi Omar.

    After I’ve changed max_input_vars value in php.ini file to 3000 I got the same error on homepage.
    It says that limit is 1000 again but it is not.

    We can’t lose our content again, this is too stressful…

    <br /> <b>Warning</b>: parse_str(): Input variables exceeded 1000. To increase the limit change max_input_vars in php.ini. in <b>/var/www/fortunasailingyacht.com/wp-content/themes/fortuna/creiden-framework/content-builder/saved-blocks.php</b> on line <b>38</b><br />

    UPDATE:
    After I’ve set and submitted third pricing table, after reload, middle pricing table jumped to the beginning and erased 2 price tables before and one text block…

    I do not understand what is happening.


    Omar
    Keymaster
    #4035

    Hello YachtMaster,

    I am so sorry for you frustration. I can understand.
    I guess the server reverted back to 1000
    can you please check with the hosting company why this happened?

    I am sure it didn’t change by it self, it must be either a server setting or the hosting providers have changed it manually.

    Regards


    yachtmaster
    Participant
    #4036

    I have access to server and I’ve set this value yesterday to 3000. Somehow error reports that this number is still 1000 but when I open php.ini file it clearly says value is 3000. Apache service was reloaded as it should be after the change.


    Omar
    Keymaster
    #4037

    An easy way to know the current actual setting on the server is adding

    <?php echo ini_get(‘max_input_vars’); ?>

    please add it to footer.php
    right before the </body> closing tag
    view any front end page, which will show the value on at the bottom of the page.

    It’s possible that the value in your php.ini is overridden by another php.ini file with higher priority.
    You can confirm this with your hosting providers telling them which file you edited.

    Regards


    yachtmaster
    Participant
    #4038

    I’ve used grep to search in all folders on server, I’ve changed all max_input_vars from 1000 to 3000.
    Error is still here.


    Omar
    Keymaster
    #4040

    Hello YachtMaster,

    If you are not on a dedicated server, (shared hosting plan, or a Virtual Private Server)
    The php.ini might be loaded from somewhere on a level higher than your server view.

    I truly apologize if I am not adequate in my replies regarding Servers, I am only sharing my experience regarding server.

    Please contact your hosting providers and let me know if possible, their reply.

    Regards


    yachtmaster
    Participant
    #4041

    Omar, we’ve found the error. String ‘;’ was not removed and max_input_vars was defined as comment.
    Now we have value of 3000 for max_input_vars…

    Stupid mistake.


    Omar
    Keymaster
    #4042

    What a relief,

    I know how a semi column can be frustrating.
    I honestly wish you a good day, and hope you don’t encounter any more troubles.
    but if you do, please don’t hesitate to contact me again.

    Cheers

Viewing 11 posts - 31 through 41 (of 41 total)

The topic ‘Edit Page Timing Out & Pre Saved Template Missing’ is closed to new replies.