Font size and scrolling problem

Tagged: ,

  • Font size and scrolling problem
    Viewing 10 posts - 1 through 10 (of 10 total)

  • oliver
    Participant
    #4202

    Hello!

    I’ve recently bought/installed your theme and most of it is great, thank you. I have two small problems that I can’t work out and was wondering if you could help.

    1 — font size.

    I found the paragraph font to be a bit small so I changed the default size in appearance/theme options/style settings/general. Now what happens is when I load a page it loads first with the small font then does a quick refresh to make the font bigger. Do you know why this is happening and how I can get the larger font to load straight away?

    2 — scrolling issue.

    On quite a few of my pages I can’t scroll down properly. What happens is that as I get near the bottom the footer starts to appear but it sort of flashes over the content. My page sort of bounces up/down/up/down and I can never get to the bottom properly, so I can’t finish reading the page.

    I’ve had a look on two computers and the text thing happens on Chrome and IE for both. The scrolling issue, however, is only a problem on Chrome — on IE it works properly.

    Here’s a page that is affected by both issues at the moment:
    http://www.civicwebmedia.com.au/services/websites/

    Any help would be much appreciated.

    Thanks,
    Oliver.


    Omar
    Keymaster
    #4203

    Hello Oliver,

    Thank you for your post, and kind words.

    1- This is because the new style is loaded through the file style.php
    to get quicker results, please go to Theme Options/General/Advanced and add in the Custom CSS Panel

    p{
    font-size: 16px;
    }

    2- Regarding the scrolling problem, I believe it’s in the content, maybe something got missing.
    Can you please try adding some generic test text? only one really long paragraph

    If you could allow me admin access so that I could test it, I would be able to be more accurate.
    feel free to comment access in a private reply, or email us on support@creiden.com

    Regards


    Omar
    Keymaster
    #4204

    Hello Again Oliver,

    Sorry for the mistake, your content is fine, the issue is because you are using Sticky header with content just equal to the page height.
    so if you add more content or remove some content or discard the sticky, it will work

    I’ve also noticed that the header is a bit large, please feel free to use the following code, to make the sticky header a bit more slim.
    Again in Theme Options/General/Advanced Custom CSS


    .sticky #logoWrapper img {
    width: 70px;
    height: auto;
    left: 28% !important;
    }
    .sticky #logoWrapper {
    height: 60px !important;
    }
    .sticky .navbar.right {
    height: 40px;
    padding: 0px;
    }
    .sticky .mainHeader .navbar .nav > li > a{
    padding-bottom: 0 !important;
    }

    Cheers


    oliver
    Participant
    #4211

    Thank you for your prompt reply.

    The text fix worked perfectly, thank you, and I’ve included the other one in the code box but I’m not entirely sure if it’s made a difference.

    I’ll be back if I have any more problems. 🙂


    oliver
    Participant
    #4212

    Sorry, just to confirm, with the scrolling problem it’s simply a case of when it happens to make the content box a bit bigger? Will this be a problem for people with different resolutions/screen sizes?

    Also, with the header, is is possible to make it a bit more compact. To me it looks like there’s a lot of space between the words in the menu and the blue underline that comes when you hover over.


    Omar
    Keymaster
    #4213

    Hello Oliver,

    Sorry for the untimely reply.
    We’re working on a fix for the content box size, we’ll update you soon about it 🙂

    Add the following to the Custom CSS to get the perfect blue line when hovering,

    .mainHeader .navbar .nav > li > a {
    padding-bottom: 18px !important;
    }

    By the way, did the other code work for you when scrolling? the sticky menu I mean.

    Regards


    oliver
    Participant
    #4215

    Thanks for your reply, I really appreciate you trying to help. 🙂

    No, I still had the scrolling issue up to this morning so I’ve decided to unsticky my heading.

    This new bit of code doesn’t seem to work either. I even changed it to 1px and there’s still a big gap (checked on box IE and Chrome). Is there something I’ve done wrong when I’ve put the code in? I’ve just been pasting each one under the other.


    Omar
    Keymaster
    #4216

    No, you’ve added them correctly.
    It seems the it’s not overriding the style.php
    please edit the file themes/circleflip/style.php

    find

    .mainHeader .navbar .nav > li > a {
    padding-bottom: calc(137px/2 – 33px) !important;
    }

    and remove that !important.
    So that it becomes

    .mainHeader .navbar .nav > li > a {
    padding-bottom: calc(137px/2 – 33px);
    }

    We’ll apply this to the next update for everyone 🙂

    Let me know if that does it.
    Cheers


    oliver
    Participant
    #4218

    Perfect, thank you!

    The original code was slightly different to what you had, but I replaced it with your new one and that works fine. Is it better to have the fixed numbers or to have the fancier code without the !important?

    .mainHeader .navbar .nav > li > a {
    padding-bottom: calc(<?php echo cr_get_option(‘header_height’);?>px/2 – 33px) !important;


    Omar
    Keymaster
    #4219

    Great!

    Yes in deed, we’ll work out a way without the !important

    Thanks for your feedback, and let us know if there is anything else you need 🙂

    Cheers

Viewing 10 posts - 1 through 10 (of 10 total)

The topic ‘Font size and scrolling problem’ is closed to new replies.