Portfolio-Cats empty on page load

  • Portfolio-Cats empty on page load
    Viewing 11 posts - 1 through 11 (of 11 total)

  • michael48769
    Participant
    #7417

    1.) When I open a portfolio category to view all the posts in this category, the category is empty??? The posts are not shown. I first have to click on the category again to have all the posts displayed. You can see this behaviour on your site too: http://themes.creiden.com/circleflip/builder-demo/circleflip-portfolio-cats/audio/
    2.) Please give me hint, how I can change the layout of this portfolio category listings. Thanks.


    Omar
    Keymaster
    #7442

    Hey Michael,

    Thank for your feedback!
    Please edit the file circleflip/templates/template-portfolio.php
    and find the line 115

    <li data-dimension="category" d ata-filter=".category-<?php echo esc_attr($category->term_id) ?>">

    and change it be

    <li data-dimension="category" d ata-filter=".category-<?php echo esc_attr($category->term_id) ?>" class="<?php echo strtolower(esc_html($category->name)) ?>">

    And add the following to the Custom Code panel at Theme Options >> General >> Advanced >> Custom Code

    <script type="text/javascript">
    jQuery.document.ready(function(){
    var miclocation = window.location.href;
    if (miclocation.indexOf('portfolio-cat') != -1) {
    var micisportfolio = miclocation.indexOf('portfolio-cats');
    var miclocationlength = window.location.href.length;
    var miccat = window.location.href.substring(micisportfolio+15, miclocationlength-1);
    jQuery("#circleflip-filters li."+ miccat +"").click()
    };
    });
    </script>

    Let me know how it goes, and let me know if you want me to log in and add those edits for you

    Cheers


    michael48769
    Participant
    #7472

    Omar, thanks for your answer. Unfortunately it doesn’t work. I’m sorry. Did you test this code on your demo-site (http://themes.creiden.com/circleflip/builder-demo/circleflip-portfolio-cats/audio/)? It seems, that it still doesn’t work on your site too??? The category links on the portfolio category page doesn’t work at all, when I add the class on line 115 in the template-portfolio.php file. Is this a bug on your side or is this something I’m doing wrong? I think it is a bug because you can see the same issue on your demo-page.


    michael48769
    Participant
    #7473

    Hi, I’ve got it working. You had a little mistake in your js-code. With “jQuery(document).ready(function(){” in the first line it should work. Thank you very much for your help and your code!!!


    Omar
    Keymaster
    #7480

    Hey Michael,

    You’re right!
    I’ve missed the document.ready indeed, sorry for that.
    And yes it’s a bug on our side and we’ll include the fix on our next update 🙂

    Thanks again for your cooperation.
    Please let us know if you face anything else.

    Cheers


    michael48769
    Participant
    #7484
    This reply has been marked as private.

    michael48769
    Participant
    #7513

    As I told you in the private Post the bug is still there but I think I found a fix. You have to check this out. It seems to work for me. You don’t have to change the “circleflip/templates/template-portfolio.php” file nor you have to add the code to the Custom Code panel. I changed the file: /circleflip/inc/cpt/portfolio/js/front.js

    The two lines with the “circleflipMixitupConfig”-object I commented out (should be line 9 + 10). I haven’t found any class definition of this object? And at the end (after line 43) I added this code:

    var miclocation = window.location.href;
    if (miclocation.indexOf(‘portfolio-cats’) != -1 || miclocation.indexOf(‘portfolio-tags’) != -1) {
    if(miclocation.indexOf(‘portfolio-cats’) != -1) var micisportfolio = miclocation.indexOf(‘portfolio-cats’);
    else var micisportfolio = miclocation.indexOf(‘portfolio-tags’);
    var miclocationlength = window.location.href.length;
    var miccat = window.location.href.substring(micisportfolio+15, miclocationlength-1);
    var $this = $( “#circleflip-filters li.”+ miccat +”” );
    filters.removeClass( ‘active’ );
    $this.addClass( ‘active’ );
    container.isotope( {filter: $this.data( ‘filter’ )} );
    }

    Let me know, if this solution is practicable.

    I spent too much time with your theme… I thought it would be easier to customize and I haven’t expected to remove bugs. I’ve bought it, because I wanted to save time. I have another issue, I will post later or tomorrow. Thanks again.


    michael48769
    Participant
    #7521

    Sorry I made a little mistake. Your changes in the file circleflip/templates/template-portfolio.php we still need, together with the changes in file /circleflip/inc/cpt/portfolio/js/front.js as described. Sorry for this confusion!


    Omar
    Keymaster
    #7542

    Hello Michael

    I apologize for the time loss this have caused.

    I apologize again, but I am confused, what’s the status now? is it working?
    I have handled this to the dev team and they are doing their best, but they’re still stuck there.

    I will update you and all the client once we get a solution for this.

    Alternatively you can use a post block, to display only a category of portfolios in each page

    Please let me know if you need help setting this up

    Regards


    michael48769
    Participant
    #7553

    Dear Omar, yes, with the changes in /circleflip/inc/cpt/portfolio/js/front.js (see above) it is working now. Thank you very much for your help. It’s good to see, that I’m not alone 🙂 Sorry for the confusion.


    Omar
    Keymaster
    #7556

    Hey Michael,

    Thanks for the update 😀

    Glad it worked

    Cheers

Viewing 11 posts - 1 through 11 (of 11 total)

The topic ‘Portfolio-Cats empty on page load’ is closed to new replies.