Uable to publish changes

  • Uable to publish changes
    Viewing 10 posts - 1 through 10 (of 10 total)

  • lazenbypt
    Participant
    #4282

    Hi there,

    Sorry for having to start a new thread with my issue, but I have tried as best I could what I found in other discussions, and I’m just now sure where to go as nothing as worked.

    I am experiencing the same issue as others (presumably since the wordpress 4.3 upgrade?) where opening a text block, making changes, and updating the page does not subsequently show the changes on the live website.

    Things I have tried so far that have made no improvement:
    – Rebuilding the page(s)
    – Upgrading PHP to version 5.6.10
    – Adding ‘max_input_vars = 5000’ to php.ini
    – Rolling out the recent updates to the circleflip template, including the most recent on 2nd Sept.

    I noted in another post that you recommended against downgrading wordpress from 4.3 so I have not attempted that yet, but was unsure if the 2nd sept release should have resolved the problem?

    Is there anything else I can try, or a way to workaround the issue, as the text updates needed are becoming quite urgent for the business owner.

    Many thanks in advance!


    Omar
    Keymaster
    #4286

    Hello Lazenbypt,

    Thank you very much for the detailed post,
    As you have already tried all previously posted fixes, please allow me admin access to your WP installation so that I could check it out for you.

    Feel free to post it in a private post, or email us with the credentials at support@creiden.com

    Regards


    lazenbypt
    Participant
    #4288
    This reply has been marked as private.

    Omar
    Keymaster
    #4289

    Hello Craig,

    I see you’re running CircleFlip 1.6
    A lot of useful updates were included since then, including some awesome features (including a header builder), and more importantly really important bug fixes
    Including:
    1- a solution for the max input vars, by reducing the amount sent by almost half.
    2- a security issue WP have issues “Escaping urls”
    ref: https://blog.sucuri.net/2015/04/security-advisory-xss-vulnerability-affecting-multiple-wordpress-plugins.html
    3- multiple minor fixes

    So If you have not altered the code, you should follow those few steps and you’ll be good to go.
    1- backup your database
    2- backup your themefiles ( Or the whole WordPress installation if convenient )
    3- download the latest version from themeforest
    4- upload to the server updating old files
    5- activate theme and check the website

    Please let me know if there is anything you need help with regarding updating.

    Regards

    P.S: Website looking great, I have a suggestion, if I may, you can use an “Image block” instead of “Team Member” in the “/Testimonials” page, where you can have the font image show the Before and the back show the After


    lazenbypt
    Participant
    #4292

    Hi,

    Thanks very much for this! Apologies for having to ask further, but I’d copied over the latest theme updates to the server, thinking that was all that was needed? I have simply been downloading the update from themeforest and replacing the ‘circleflip’ folder in it’s entirety in wp-content/themes folder. Is there another (probably very obvious step!) to updating the theme that i am missing?

    Thank you for the testimonials page advice – the trainer who owns the site decide to start making changes to that one himself without my supervision, but I will have a look at it with him!!

    Thanks.


    Omar
    Keymaster
    #4293

    Hello Craig,

    You didn’t miss anything, sorry for not mentioning this, but as of WP 4.3 you should use the customizer for the favicon.

    Here’s how
    https://codex.wordpress.org/Creating_a_Favicon

    Please let me know if you need any help

    Cheers


    lazenbypt
    Participant
    #4305

    Hi,

    Sorry, was this reply to another post?

    Setting up a favicon is a good idea, but doesn’t really help with upgrading the circleflip version 🙂

    I’ve copied over the contents of the updated circleflip to the themes folder, so not sure why its still the older version and what I’ve missed?

    Thanks as always!


    Omar
    Keymaster
    #4316

    Hello Craig,

    Thanks for your Thanks, and sorry for the untimely response.

    It seems that I did mess up my replies! Sorry for that 😀

    I see it still says 1.6

    I suggest trying the envato WordPress tool kit for the update, It’s faster and more reliable.
    Please backup your installation first, along with an export of the DB
    and install the plugin https://github.com/envato/envato-wordpress-toolkit/archive/master.zip

    then update the theme using the plugin dashboard

    Cheers


    lazenbypt
    Participant
    #4317

    Thanks for the update! I am sorry to keep bothering you with this, but with Envato toolkit, I only get ‘couldn’t connect to host’ instead of being able to access circleflip. I have triplechecked the API key and it is correct, and the only other troubleshooting advice I can find is to check with the template author; but I’m assuming there’s nothing to check, since you’re the one recommending the plugin, so I’m assuming it should work.
    I can’t see anything in my hosting dashboard that would be blocking the Envato API, and I still can’t understand why the theme did not update manually from copying over the folder into the server.
    So I’m not sure how to proceed…can you suggest anything else please?


    Omar
    Keymaster
    #4318

    Hey Craig,

    Let’s try going the whole ten yards.
    -Why don’t you backup the current theme (by zipping it for example) and download it or copy it elsewhere in the server.
    – add any maintenance plugin, for example (https://wordpress.org/plugins/wp-maintenance-mode/)
    – after activating the plugin, which will say to visitors something like (we’ll be right back)
    – activate a default theme (twentyfifteen for example)
    – delete the circleflip theme folder from the server. (after making sure the backed up is safe elsewhere)
    – upload the new one you downloaded (make sure it’s 2.2.3 by opening the file style.css)
    – after uploading and activating the theme, you can check if all is good then disable the maintenance plugin

    Hope this works.

    Cheers

Viewing 10 posts - 1 through 10 (of 10 total)

The topic ‘Uable to publish changes’ is closed to new replies.